CBR250 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My bike is an Australian model 1999 cbr250rr, I am not what the problem may be but I will try describe it to the best of my ability.

Basically, my bike randomly stalls when riding, not during traffic lights, like during riding.

The first time it happened when I was in 6th gear and I pull back the throttle to gain speed rather than downshifting to gain speed
faster, and as I twisted the throttle, the power was cut and the engine stalled. Basically, I tried to restart in gear but it would
not start, BUT when I started in it neutral it did start and idled fine. But when I tried to select a gear while it was running in neutral,
once I had entered the gear 1st or 2nd it would instantly stall. So, I tried to turn it on, on neutral again and it worked and reved fine
so I tried selecting a gear and and it would constantly stall. Weirdly about an hour later, after getting picked up and towing the bike
back to my house, I started in it neutral and was able to select a gear and ride. It had a weird sound but was ride-able.

The second time, it happened again a week later, I was downshifting heavily to 2nd gear and it just stalled with the exact same problems
as before. Able to start in neutral but not in any other gear, and when selecting any gear while the bike was on in neutral, it would instantly
stall. And somehow also, after about 30mins/1hr pushing it home, it would start in gear again.

I had a full service @ Lloyd Penns in December. They cleaned carbs, balanced valves, and either a normal full service includes.
I just want to know the problem, and see if I am able to fix it myself.

Thanks in advance guys.
 

·
Registered
Joined
·
70 Posts
Possibly the side stand switch is acting up. Use a multimeter with continuity and see if the stand operates the switch properly. If it looks alright I'd still bridge the wires so it isn't a factor and see if the problems persist.
 
1 - 3 of 3 Posts
Top