CBR250 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
HI, no fire on the spark plug on my cbr, coil, ignition coil, fuel pump, Ecu,injector and wiring all these are good, any idea of what could be the problem
 

·
Registered
Joined
·
21 Posts
Hi, What year is your bike? Fastest way to solve this issue (5-10 min max) is to measure voltage at critical spots:

1. battery voltage (bike off) = ?
2. key ON, measure voltage at power-input to each coil black/blue wire/terminal. What is voltage at coil power-input?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Hi, it's year 2014 bro,
Battery is full charge as i put a new battery and charge it before 13.8 volt
Black /white is 13 volt bro
Do you think the lean angle is faulty
 

·
Registered
Joined
·
21 Posts
Does it crank? But no spark?

bank-angle sensor would disable starter so it won’t crank at all.

what changed between when it was working and now?
Anything get adjusted or changed?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Yes it crank but no spark, even if you unplug bank- angle sensor it cranks but no spark, we change nothing bro, the bike was running well and last two week i put start but engine crank but can't start bro, it's not the Ecu as i got one to replace
 

·
Registered
Joined
·
21 Posts
To troubleshoot, you must test and measure every part. The NUMBERS will tell you if a part is bad or good. Then replace part only when it’s confirmed bad. Randomly replacing perfectly working parts with brand-new perfectly working parts changes nothing and bike still won’t start.

Most likely wiring issue, could be no power going to ECU, or no power going to coils. Measuring for voltage is ONLY way to diagnose this problem and find where power stops flowing. Start with those tests outline above. The numbers will show which tests to do next to narrow down this issue. It can be simple 5-10 minute procedure once we have numbers.

sorry, i got wire colour wrong, it’s black/blue that powers coil.

3. key ON, measure voltage at red/white wire going into ignition-switch
4. key ON, measure voltage at black/red wire coming out of ignition-switch
5. key ON, measure voltage at black/green wire going into start/stop switch
6. key ON, start/stop ON, measure voltage at black/blue wire leaving start/stop switch
7. key ON, start/stop ON, measure voltage at black/blue wire at ECU connector
8. key ON, start/stop ON, measure battery voltage when cranking engine

do you have any aftermarket electronics on bike? Turn-signals? USB phone chargers , GPS, heated gloves, heated seats, radar detector, stereo, AC?

How are you determining you have no spark?
Do you have or have access to oscilloscope?
Does neutral light turn on?
Is ignition switch original one that came with bike?
 
1 - 6 of 6 Posts
Top