CBR250 Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Having a problem with my mc19 1989 model the speedo is displaying 10kmh at standstill anyone know the reason behind this?
Any helps appreciated

Will upload a photo later if needed


Cheers Ratbag
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
What do you mean? The speedo might be off an mc22 ?
Can you recommend anyone for a replacement ? or a second hand stock one?
 

·
Registered
Joined
·
36 Posts
Does it start moving up right away when you start rolling, or does it stay still until you reach approximately 10 km/h and then start to move? Does it move at all? It may just be as simple as the needle being stuck and not being able to drop below 10 km/h with everything else working just fine.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
It only moves after you reach 10kmh , however i will double check it doesn't come in earlier then that, this weekend.
Do you know if anyone else has had a similar problem?
 

·
Registered
Joined
·
2 Posts
Hi I have a similar problem when I turn on my mc22 the rev meddle move when I press the start button it bounces between four and six but when I drive the bike and accelerate it doesn’t move can you try and diagnose this for me please and thanks 🙏
 

·
Registered
Joined
·
62 Posts
I wonder if the needle has been pulled off before and not placed back in right spot if that makes sense..

I may have a second mc19 speedo only. Where are you located
 

·
Registered
Joined
·
13 Posts
Discussion Starter #10
I wonder if the needle has been pulled off before and not placed back in right spot if that makes sense..

I may have a second mc19 speedo only. Where are you located
Hi sorry ive taken some time to get back to , so how would i take the needle off does it have a grub screw also it appears to have been fixed/glued back on at some point so you are most likely correct i will have a look this coming weekend and get back

In regards to your second hand one im located in the eastern suburb's of Melbourne , also how much were you thinking price wise and any pictures would be great
 

·
Registered
Joined
·
13 Posts
Discussion Starter #11 (Edited)
Update

I took apart the entire assembly of the speedo today and found that the spring that returns the needle to its original position hand stretched somewhat , to fix this i just put the spring under tension and then moved the needle itself buy just rotating it by hand until it was just touching the post that stops it from looping / base position

Here is how to take the speedo out of the housing:
IMG_20181010_161445723_L2.jpg Removing this plug enables you to remove the speedo entirely making it easier to work on , just dont forget to remove the 4 screws that hold the casing front on , and the cable clamp in white




IMG_20181010_161440856.jpg Here is the wire for the speedo to disconnect , i believe it is the sensor for the speed cutout once over 180 kmh



IMG_20181010_161427280_LI.jpg Here is were the cable pops out its quite tricky but will come out just dont force it as you dont want to break the housing or the connector


IMG_20181010_161421373.jpg This is the assembly taken out completed allowing to position the needle to lowest/base point




However i did break the clips that hold on the dash plate and the bit of foam and was wondering if anyone knows where i can get them , aswell as some dash lights as i noticed some of mine were blown
IMG_20181010_180001983.jpg

IMG_20181010_175950547.jpg

This job was relatively easy however it looks daunting when you first open the case but once its out its quite easy to understand how the whole speedo works


Any help regarding the clips/pins and the globes/lights would be appreciated thanks
 
1 - 12 of 12 Posts
Top